Print screen doesn't work

Please note that the behaviour of the "Print Screen" key (and certain other special Windows key combinations) in the Windows version of VNC Viewer can be modified by the "Pass special keys directly to VNC Server" setting. See

http://www.realvnc.com/products/enterprise/4.6/docs/af1016150.html#Raf14482

for details.

By default, this option is ON, so pressing "Print Screen" in a Windows VNC Viewer window will actually result in the key press being sent to the VNC Server machine (which will be interpreted differently depending on the OS running on that machine).

If you simply want to obtain a screen capture of the VNC Server machine and have it available on the VNC Viewer machine, you can either:

A) Leave this option on and handle all the screen capturing on the remote machine. E.g. on a Windows VNC Server machine, the "Print Screen" key will capture the screen to the clipboard, and it can be pasted into an image manipulation program such as Paint on that machine via keyboard/mouse input from the Viewer. The resulting file can then be transferred to the VNC Viewer machine via the File Transfer feature.

B) Turn this option OFF and handle the screen capturing on the local (VNC Viewer) machine. E.g. on Windows, pressing Alt + Print Screen will capture the active window, which you can ensure is the VNC Viewer window by clicking on it. Again, this will store an image in the Windows clipboard, and this can be pasted into Paint or another suitable application on the VNC Viewer machine.



Related Articles

No related articles were found.

Attachments

No attachments were found.

Visitor Comments

Article Details

Last Updated
12th of June, 2012

Would you like to...

Print this page  Print this page

Email this page  Email this page

Post a comment  Post a comment

 Subscribe me

Subscribe me  Add to favorites

Remove Highlighting Remove Highlighting

Edit this Article

Quick Edit

Export to PDF


User Opinions

75% thumbs up 25% thumbs down (8 votes)

How would you rate this answer?




Thank you for rating this answer.

Continue