I'm getting a black screen when I connect to VNC Server

The main reasons you may encounter this are:

* You're connecting to Windows Media Center or similar software
* You're trying to connect to a computer that's using Fast User Switching (i.e. you are in a switched out session)

The workaround for Windows Media Center is below. We do not support Fast User Switching, the workaround in this situation is to login to a non switched-out session.

This is likely due to the VNC Mirror Driver, which will be attempting to capture the hardware accelerated video / menus, but is unable to do so by design. You can either lower machine hardware acceleration (this shouldn't impact machine performance, depending on the speed of the machine or the graphical intensity of the video) or you can enable a different update method, instead of the VNC Mirror Driver.

To lower the computer's hardware acceleration:

Windows XP:

Control Panel > Display > Settings > Advanced > Troubleshoot

Windows Vista:

Control Panel > Personalization > Display Settings > Advanced Settings > Troubleshoot

Windows 7:

Control Panel > Appearance and Personalization > Display > Change display settings > Advanced settings > Troubleshoot

If this doesn't work, try playing with the update method settings. Set the UpdateMethod parameter (in VNC Server options, Expert tab) from 2, to 1. If this doesn't work, try setting it to 0.

0 = Polling (Slower over low bandwidth, but will capture the entire framebuffer)
1 = VNC Hooks (Fairly efficient "all-round" update method, but may miss certain GDI hooks in the framebuffer)
2 = VNC Mirror Driver (Extremely fast/efficient capture method, but may miss certain video/3D related events).

* The VNC Mirror Driver should be in use where possible, to provide better performance.
* For times when a 3D application/video cannot be remoted, reverting to VNC Hooks will most likely provide updates, but the performance will be degraded.

AMX Touchpanel

There are some further settings that need to be changed to support AMX Touchpanel:

Go to VNC Viewer -> Options -> "Adapt to network speed" and uncheck the tickbox.

Then the "ColourLevel" needs to be changed. Go to Expert tab -> ColourLevel and change the default value to "rgb565".

Intel HD graphics card

There are known issues with Intel HD graphics cards in headless mode.  Please see the related article for further information and workaround.

Still not working?

If the above workarounds don't work for you, try simply either minimising the application that is causing you problems, or if it's running in full screen mode, run it in windowed mode. Reconnecting may be required.



Related Articles

Attachments

No attachments were found.

Visitor Comments

Article Details

Last Updated
12th of March, 2014

Would you like to...

Print this page  Print this page

Email this page  Email this page

Post a comment  Post a comment

 Subscribe me

Subscribe me  Add to favorites

Remove Highlighting Remove Highlighting

Edit this Article

Quick Edit

Export to PDF


User Opinions

60% thumbs up 40% thumbs down (20 votes)

How would you rate this answer?




Thank you for rating this answer.

Continue